After Update to 2.1-7, RBL doesn't work anymore

This is the area for a general support questions, discussions and information that you can read and share. Post your experiences, stats and tricks and tips that are not covered elsewhere. Remember, for questions please search the FAQ first, as your question may already be answered.

Moderators: wizard, magicspam

Post Reply
i6media
Posts: 1
Joined: Wed Aug 02, 2017 6:01 am

After Update to 2.1-7, RBL doesn't work anymore

Post by i6media » Wed Aug 02, 2017 6:04 am

Hi,

After upgrading to 2.1-7 (Centos 7 x64), every e-mail is being blocked by the RBL.

We've tried deleting, restarting etc, but no e-mail is getting passed by the RBL services:

(RBL-Host: b.barracudacentral.org)
(RBL-Host: psbl.surriel.com)
(RBL-Host: zen.spamhaus.org)
(RBL-Host: cbl.abuseat.org)

We've currently disabled all RBL hosts, but by doing this a lot of SPAM will go through.

Anyone else experiencing this issue, or how to resolve this?

Thanks in advance.

magicspam
Posts: 1058
Joined: Tue Oct 28, 2008 2:27 pm

Re: After Update to 2.1-7, RBL doesn't work anymore

Post by magicspam » Wed Aug 02, 2017 2:14 pm

We just released an updated version 2.1-7.1 that addresses this issue.

The short end of this is that the updates to our DNS Resolver engine for supporting things like Multi-PTR responses, AAAA only responses,etc. had an unexpected side effect with RBL lookups in that it caused RBL lookups to start using the 'search <domain.tld>' parameter of /etc/resolv.conf.

We found this caused issues similar to what you (and others) have reported for cases where the 'domain.tld' value also happened to have a wildcard host record (eg: *.domain.tld).

You can upgrade by visiting the MagicSpam interface 'Alerts' tab, and click on "Upgrade Now" in the newly posted upgrade notification.

Thanks to you and all others who reported this!
-- MagicSpam Support Team --

Post Reply

Return to “General Discussions and Support Questions”

Who is online

Users browsing this forum: No registered users and 3 guests