MagicSpam & Cluster configuration

There will always be opinions, both good and bad on how MagicSpam protection, rules and policies are used, and what the defaults should be. Different environments may have different needs. We try to find the perfect balance, and that is not always easy. Just remember that we have to satisfy millions of users.. not just one person.

Moderators: wizard, magicspam

Post Reply
cqi
Posts: 6
Joined: Thu Jul 22, 2010 7:03 am

MagicSpam & Cluster configuration

Post by cqi » Fri Aug 06, 2010 6:45 am

Hello:

I'm currently having an issue with MagicSpam and my Cluster Manager. I have Mail Enable services registered with Cluster Manager but when MagicSpam updates at intervals 0, 6, 12, and 18, it stops and starts the SMTP service which causes the registered cluster resource to fail. When Cluster Manager sees this, it tries to restart the service. Sometimes that works but other times I get an error that says Mail Enable could not bind to my ip address and the service fails altogether. I suppose this is because the Cluster is trying to bring the serivce on while other tasks are using the port. At that point, my users can't send any emails and I get the support call.

So, I have be researching a way around it and have come up with the idea that I could write a bat file that takes the resource offline, calls the magicspam updater, then brings the resource online. However, when I test the bat file and call the magicspam updater, it takes at least a minute or 2 then comes back with a "null" message. Am I doing something wrong? I see where the schedule task is just calling the same file and that's all I'm doing in the bat file.

Any suggestions? I also see where Cluster Manager has a "mainteance" option switch. I researched Cluster Manager command line tools to get my command line options.

magicspam
Posts: 1040
Joined: Tue Oct 28, 2008 2:27 pm

Re: MagicSpam & Cluster configuration

Post by magicspam » Fri Aug 06, 2010 10:19 am

Could you please send us the portion of your batch file which deals with MagicSpam? You may be calling the updater incorrectly.
-- MagicSpam Support Team --

cqi
Posts: 6
Joined: Thu Jul 22, 2010 7:03 am

Re: MagicSpam & Cluster configuration

Post by cqi » Fri Aug 06, 2010 12:17 pm

Something like this?

cluster resource "SMTP" /offline
magicspam-updater.exe
cluster resource "SMTP" /online

Also, can you tell me what is being updated when the process happens?

magicspam
Posts: 1040
Joined: Tue Oct 28, 2008 2:27 pm

Re: MagicSpam & Cluster configuration

Post by magicspam » Mon Aug 09, 2010 12:33 pm

Our developers have been in contact with you via email. This issue is now being handled there.
-- MagicSpam Support Team --

Post Reply

Return to “Discussions on Spam Protection Policies and Default Rules”

Who is online

Users browsing this forum: No registered users and 1 guest